Polyfill required to use TinaCMS with Webpack5

I’m using webpack5 for my project. Following along with the getting started tutorial, I ran into a roadblock when I received the following error building my project:

ERROR in ./node_modules/tinacms/build/index.js 1:460-475
  Module not found: Error: Can't resolve 'path' in '<my-project-path>/node_modules/tinacms/build'

BREAKING CHANGE: webpack < 5 used to include polyfills for node.js core modules by default.
  This is no longer the case. Verify if you need this module and configure a polyfill for it.

  If you want to include a polyfill, you need to:
  	- add a fallback 'resolve.fallback: { "path": require.resolve("path-browserify") }'
  	- install 'path-browserify'
  If you don't want to include a polyfill, you can use an empty module like this:
  	resolve.fallback: { "path": false }

Is this a known issue? I had to install the path-browserify and create a fallback webpack configuration. I found this similar issue on SO which helped me get past this issue.

I’m pretty much a noobie, so apologies if I missed where this was covered in the docs, but this seems like it should warrant a warning and a troubleshooting message. I had a hard time finding a solution in the Tina ecosystem. Also, is there work being done to better support Webpack5?

Thanks for the feedback, we haven’t tested our tutorial with webpack 5, glad you got it working :sweat_smile: