Group-list not working in the useForm - NextJS project

Hello everyone, we are trying to integrate the group-list component in the sidebar but it simply doesn’t work. Unfortunately, the documentation lacks information about the full process of how to use the group-list component:

Is there any way that you can provide a full example to see how the implementation needs to be done?

Following the example in the documentation, that’s the issue that I’m getting:

connectAdvanced.js:245 Uncaught Error: Could not find "store" in the context of "Connect(Droppable)". Either wrap the root component in a <Provider>, or pass a custom React context provider to <Provider> and the corresponding React context consumer to Connect(Droppable) in connect options.

Thanks in advance.

Hey there, you can see an example of group list being implemented on the home page

If you have any example code or a link to a repo where you’re experiencing issues, that should help with further troubleshooting!

I am having the same exact issue when implementing group-list into the sidebar. I’ve tried with blocks and it also gives the same error. Something to do with the draggable/droppable feature.

@kendall The example in the link you provided is using inline form. One of my colleagues have tried using group-list in an inline form and it worked. Is there an example of implementation for the sidebar?

I already disposed my code so I have no example to show but I basically just tried out the example in the documentation and it’s not working.

1 Like

@mishi, the example I shared was for a sidebar form. The group-list is only available as a sidebar field. I just checked a different test case on demo-gatsby in the tinacms monorepo and I can’t reproduce this issue, even if I remove the inline form and fields entirely. I’ll try to add a group-list to the demo-next package in the monorepo to test this further.

Please feel free to make an issue in the repository with steps to reproduce!

Hi @kendall! Thanks for your reply. Sorry for the late response, I got caught with other tasks.
Anyway, I was wondering if you have tested this out on just plain React project?

I found out why this wasn’t working for me and thought I’d share it here for anybody who might run into the same issue in the future. The package material-table somehow caused the error – maybe some conflict or incompatibility (I didn’t investigate further). But uninstalling that solved my problem.


Thanks for sharing with us how you solved your issue.
All the best Mishi

1 Like

I am SO grateful to you for this! I never would have figured it out, otherwise. @mishi

1 Like